9 3 6 1 1

Follow TrueDelta

TrueDelta at Facebook TrueDelta at Google+ TrueDelta at Twitter

2010 Mercury Milan Transmission Problems

40 TrueDelta members own a 2010 Mercury Milan. 6 of these members (15%) have reported transmission repairs for their car. A total of 12 transmission repairs to 2010 Mercury Milans--an average of 0.3 per vehicle--have been reported.

See our lemon odds and nada odds page to see vehicles with no repairs or vehicles with more than three repairs. To see how frequently 2010 Mercury Milan problems occur, check out our car reliability stats.

Percentage of 2010 Mercury Milan repairs by problem area

Chart based on 51 repairs.
Non-members can see only ten 2010 Mercury Milan repair histories. Log in or join us to see them all.

2010 Mercury Milan

Engine not specified

42000 mi   Transmission was 2 quarts low. Upon checking the repairman found that the seal where the drivers side CV joint attached to the transmission was defective. 

Return to top

2010 Mercury Milan 4dr Sedan

240-horsepower 3.0L V6 6-speed shiftable automatic FWD

25500 mi   Transmission serviced per Ford Customer Satisfaction Program 10B15 

Return to top

2010 Mercury Milan 4dr Sedan

175-horsepower 2.5L I4 6-speed automatic FWD

37000 mi   Transmission programming updated under warranty to resolve hesitant shifting to Drive 
18000   Transmission was experiencing a slightly rough 1-2 and 2-3 shift. Dealer re-flashed transmission computer. 
20500   TRANSMISSION PULLED AND OVERHAULED:with the following part #'s:9L8Z 7B164 B PLATE CLUTCH/9L8Z 7B164 C DRIVE PLATE/9L8Z 7B164 D PLATE ASY -DR/9L8Z 7B442 A DRIVEN PLATE/9L8Z 7B442 E DRIVEN PLATE/BL8Z 7A100 A CONTROL ASY/BL8Z 7L238 A SUPPORT -TRANrn9L8Z 
23000   Left front Axle Axle Shaft/CVJOINT replacement.rnAE5Z 3A427 E SHAFT 
33000   Flaring during shifting into 3rd gear. Shifts better but continues to Flare when cold, after replacement of shift assembly.  
42000   Replaced the left axle 
74000 US $100 rough shifting - updated programs in transmission 
20000   from complete stop trans wouldn't engage for few seconds-when did engage made loud "clunk" & lunged; still feels like it slips; this time they replaced trans clutches and reprogrammed again 
23000   dealer installed black box for sporadic problem but would not leave on long enough for problem to occur (recurring transmission problem for which car has been in dealer @ least 9x already). occurrence happened within 5 days of removing box 
36000   Transmission issues never resolved. 

Return to top