9 5 5 1 4

Follow TrueDelta

TrueDelta at Facebook TrueDelta at Google+ TrueDelta at Twitter

2011 Ford Explorer Repair Histories

55 TrueDelta members own (or used to own) a 2011 Ford Explorer. 29 of these members (52.7%) have reported repairs for their car. A total of 87 repairs to 2011 Ford Explorers--an average of 1.6 per vehicle--have been reported.

See our lemon odds and nada odds page to see vehicles with no repairs or vehicles with more than three repairs. To see how frequently 2011 Ford Explorer problems occur, check out our car reliability stats.

{ ?>
Chart based on 87 repairs.
Non-members can see only ten 2011 Ford Explorer repair histories. Log in or join us to see them all.

2011 Ford Explorer

Engine not specified

Ford Explorer in Michigan, United States
Apr 2011 - May 2011
13000 mi   Electronic cooling fans stopped working cuasing the car to overheat when stopped. Additionally, the air conditioning stopped working directly related to the cooling system. The MYFORD SYNC system completely crashed. NAVI stopped working, phone would not stay paired, HVAC controlls would not work during system crash. System would indicate several USB connection when on 1 was plugged in. Loud wind noise in the upper right hand side of the windsheild. Wind noise is more noticalbe during windy conditions. 
Ford Explorer in Missouri, United States
Mar 2011 - Jul 2011
1000 mi   software update 
Ford Explorer in Ohio, United States
Mar 2011 - May 2011
2000 mi   Car made screeching noise from engine right after ignition. Dealer could not replicate. 

Return to top

2011 Ford Explorer 4dr SUV

290-horsepower 3.5L V6 6-speed shiftable automatic FWD

Ford Explorer in Florida, United States
Feb 2011 - Sep 2014
3000 mi   Repaired trim Radio intermittently receiving signals. 
20000   microsoft sync system has many issues and needs update that is very time consuming and not user friendly 
22000   leak from cooling system/heater core. Had to remove dash to replace part! 
31700   loose rear-view mirror 
33000 US $150 Dead battery 
52500   blend door actuator stripped and had to be replaced 
60000   shifter not going into park always. needed adjustments. 

Return to top

2011 Ford Explorer 4dr SUV

290-horsepower 3.5L V6 6-speed shiftable automatic AWD

Ford Explorer in Maryland, United States
Apr 2011 - Jun 2013
3000 mi   Water present in the right mirror turn signal indicator light. The exterior trim piece on the A-Pillar was buzzing at high speed. Attempted to pickup vehicle three times in 4 days but immediately returned with the problem. A rental was provided. 
15000   A trim piece on the outside of the A-pillar was buzzing at speed. A new redesigned trim piece has been made available to fix the problem. 
Ford Explorer in Indiana, United States
May 2011 - Sep 2014
2000 mi   both LED's on side view mirrors replaced due to condensation build up in them 
2000   replaced a module in the sync system preventing pretty much everything from working, also replaced the side mirrors again for condensation in the led lights 
3000   both side mirror replaced again due to moisture in the side indicator led's built into the mirrors.  Performed tsb on the a-pillars for the rattling noise. tsb resolved the noise. 
5300   Side mirror led on passenger side filled with water again. Mirror replaced again, for the third time. 
10000   A-pillar trim making noise again. Replaced with revised parts--Ford TSB. New designed parts are supposed to fix the problem--so far so good. 
10000   Exterior black trim piece on the inside top edge of the tailgate came loose at one end. Piece was double sticky taped back in place (that is how it was originally installed--no fasteners). 
12000   A-pillar trim fastening tab broken somehow. Trim replaced. 
21000   Front sway bar link bushings making noise--clunking over bumps at slow speed. Dealer replaced both sway arm links. 
Ford Explorer in Minnesota, United States
Apr 2011 - Jul 2011
  MFT (My ford Touch) multiple reflashs. Still very buggy but getting better. Reflashs done in May and in July. Windshield noise, dealer unable to verify. 
Ford Explorer in Ontario, Canada
Feb 2011 - Mar 2014
2480 mi   Active Park Assist not working. Diagnosed right front sensor faulty. Replacement part ordered. Replaced right front sensor to correct fault in Active Park Assist. 
4740   Rain sensing wipers would sometimes do a random wipe when there was no reason for it. Dealer replaced the processor. 
5580   A performance upgrade was installed for MyFord Touch (MFT). Many owners experienced various problems with MFT and Ford redesigned and worked on the software package. New navigation card was also installed. 
8060   Over the past few months I had to trickle charge the battery several times since it was low. Never failed to start the car. Battery was tested when I went for season tire change and the result was that the battery was replaced. 
8260   Rain sensing wipers would periodically wipe for no reason. Dealer replaced control module. This was the second time it was replaced. 
Ford Explorer in Indiana, United States
Feb 2011 - Apr 2011
1000 mi   MyFordTouch had some issues. Dealer said that they needed to update the software. Problems were, cell phone would not sync, clock not keeping time. 
Ford Explorer in Ohio, United States
Mar 2011 - Jun 2011
  ABS activated causing sudden slowdowns when taking 3-4 degree turn at 38-42 miles/hr. Replaced part BB5Z*3F818*A Sensor - Steering Rotation 
8000 mi   replaced passenger seat airbag wiring assembly... wires broke from moving the seat full forward 

Return to top