Follow TrueDelta

TrueDelta at Facebook TrueDelta at Google+ TrueDelta at Twitter

1997 Subaru Legacy Repair Histories

26 TrueDelta members own (or used to own) a 1997 Subaru Legacy. 5 of these members (19.2%) have reported repairs for their car. A total of 9 repairs to 1997 Subaru Legacys--an average of 0.3 per vehicle--have been reported.

See our lemon odds and nada odds page to see vehicles with no repairs or vehicles with more than three repairs. To see how frequently 1997 Subaru Legacy problems occur, check out our car reliability stats.

Percentage of 1997 Subaru Legacy repairs by problem area

Chart based on 9 repairs.

1997 Subaru Legacy repair cost distribution

Chart based on 6 repair trips. The repair cost chart excludes repairs made under warranty, do-it-yourself repairs, and repair trips that include maintenance.
Non-members can see only ten 1997 Subaru Legacy repair histories. Log in or join us to see them all.

1997 Subaru Legacy

Engine not specified

Subaru in West Virginia, United States
Jul 2013 - Aug 2013
Aug 2013 US $125 Bad starter 
Subaru in Tennessee, United States
Aug 2012 - Sep 2012
Sep 2012 US $510 Replaced all belts, coil pack, spark plugs, wires, oil change, fuel & air filters, tire balance, and had all lines cleaned out. 

Return to top

1997 Subaru Legacy 4-door

4-cylinder manual AWD

Subaru in West Virginia, United States
Apr 2010 - Jun 2012
Jun 2010 US $200 bought the car used with a whirring noise in transmission, drove on it for 40k mi. started slipping out of 4th gear when coasting, had to replace rear main input shaft bearing 
Aug 2011   bad wheel bearing and leaking axle stub seals. I caused the leak on the axle when I rebuilt the transmission in the past 
Apr 2012   piston froze in caliper, broken sway bar mount, bad cv boot, rust 

Return to top

1997 Subaru Legacy 4-door

4-cylinder automatic AWD

Subaru in Washington, United States
May 2010 - Jun 2012
Jun 2010 US $500 Wheel bearing hub damaged. 
Sep 2010   Check engine light has been on/off for the last 6 months and now was on constantly. Had it checked ... timing sensor was out. Had it replaced. 
Mar 2012   CV axle worn out 

Return to top